[InterMine Dev] Enrichment Widget

Vallejos, Andrew avallejos at mcw.edu
Wed Nov 4 15:37:00 GMT 2009


Thanks!

Took me a bit to figure out what I needed to change and why.

It sounds like I need to update the phenotype source so that it uses a
more sensible name than MPheno.  

Thanks again,

Andrew

-----Original Message-----
From: Julie Sullivan [mailto:julie at flymine.org] 
Sent: Wednesday, November 04, 2009 4:26 AM
To: Vallejos, Andrew
Cc: dev at intermine.org
Subject: Re: [InterMine Dev] Enrichment Widget

In the webconfig file, you have the "filters" attribute for that widget
set to 
be "mammalian_phenotype".

In your widget query, the "filters" attribute constrains
MPTerm.namespace. 
MPTerm.namespace in your database has these values:

	MPheno.ontology	6741
	[no value]	281

That's why this widget isn't returning any values, these two values need
to be 
equal.  Change the filter to be "MPheno.ontology" and the query will
return 
results (except for those 281 terms with no namespace).

GO has three main ontology groupings (biological_process,
cellular_component, 
and molecular_function) and it's not useful to analyse data across them,
which 
is why the GO widget query constrains on GOTerm.namespace.  You can
probably 
remove this constraint if you only have one namespace.

Sorry, I know it's not clear how the webconfig relates the widget query,
but 
hopefully this will improve with the next few intermine releases.

Vallejos, Andrew wrote:
> Julie,
> 
> I've attached the webconfig file.
> 
>> The widget query includes a constraint on ontology.  Can you verify
> this 
>> ontology is correct?  The DO one is 'Disease_Ontology' and the MP
> ontology >reads 'MPheno.ontology'.  Maybe that dot should be an
> underscore?
> 
> Where are you looking?
> 
> Thanks,
> 
> Andrew
> 
> -----Original Message-----
> From: Julie Sullivan [mailto:julie at flymine.org] 
> Sent: Tuesday, November 03, 2009 10:38 AM
> To: Vallejos, Andrew
> Cc: dev at intermine.org
> Subject: Re: [InterMine Dev] Enrichment Widget
> 
> Andrew,
> 
> Can you double check (or send me) your webconfig entry for that
widget?
> Is it 
> pointing to the correct loader?  Is the ontology correct?
> 
> The widget query includes a constraint on ontology.  Can you verify
this
> 
> ontology is correct?  The DO one is 'Disease_Ontology' and the MP
> ontology reads 
> 'MPheno.ontology'.  Maybe that dot should be an underscore?
> 
> 
> Vallejos, Andrew wrote:
>> I've attached two our RatMine's enrichment Loader scripts.  The
> problem 
>> is that the MP enrichment widget never processes any of the genes or 
>> proteins.  (As in "Number of Genes in this list not analysed in the 
>> widget" always equals the number of genes in the list).
>>
>>  
>>
>> The DO enrichment widget works properly.
>>
>>  
>>
>> There is nothing in the log files that I have been able to find.
>>
>>  
>>
>> Thanks,
>>
>>  
>>
>> Andrew
>>
>>  
>>
>> ======================
>>
>> Andrew Vallejos
>>
>> Web Developer II
>>
>> Biotechnology and Bioengineering Center
>>
>> Medical College of Wisconsin
>>
>> 414-955-4104
>>
>> avallejos at mcw.edu
>>
>>  
>>
>>
>>
>
------------------------------------------------------------------------
>> _______________________________________________
>> dev mailing list
>> dev at mail.intermine.org
>> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev



More information about the dev mailing list