[InterMine Dev] Javac 1.6

Vallejos, Andrew avallejos at mcw.edu
Tue Nov 10 16:12:54 GMT 2009


Hi,

 

I've recently upgraded my Mac to Snow Leopard.  Snow Leopard comes with
Java 1.6 prebuilt.  I was trying to get InterMine to build (ant build-db
in dbmodel), but I kept getting a failure to launch modern compiler
error (or Out of Memory: Heapspace error with verbose).  After running
several different ANT_OPTS, I concluded that it must be my version of
Java.

 

It took me a bit of searching online, and I did find instructions on how
to install Java 1.5 on Snow Leopard, and how to get Ant to take Java 1.5
over Java 1.6.  Once I did that the build ran successfully.

 

Have you had any experience running InterMine with Java 1.6?  I am
curious if this is an OS X issue or a Java 1.6 issue.  

 

Thanks,

 

Andrew

 

======================

Andrew Vallejos

Web Developer II

Biotechnology and Bioengineering Center

Medical College of Wisconsin

414-955-4104

avallejos at mcw.edu

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.intermine.org/pipermail/dev/attachments/20091110/46991a12/attachment.htm>


More information about the dev mailing list