[InterMine Dev] Javac 1.6

Richard Smith richard at flymine.org
Wed Nov 11 09:42:23 GMT 2009


Hi Andrew,
I have Snow Leopard on a new machine that I haven't set InterMine up on 
yet, I'l try
to do this soon and let you know.

Richard.



Matthew Wakeling wrote:
> On Tue, 10 Nov 2009, Vallejos, Andrew wrote:
>> $ echo $ANT_OPTS
>> -server -XX:MaxPermSize=1024M -Xmx2048M -XX:+UseParallelGC -Xms2048M 
>> -XX:SoftRefLRUPolicyMSPerMB=1 -XX:MaxHeapFreeRatio=99
>>
>> Pretty much inline with what the docs recommend.
>
> One possibility is that your Java 1.6 is 64-bit while your Java 1.5 is 
> 32-bit. That would make it require more memory, possibly as much as 
> double. If there is enough RAM available in the machine, try changing 
> the "-Xmx2048M" option to "-Xmx4000M". If that works, then this may be 
> the issue.
>
> Matthew
>




More information about the dev mailing list