[InterMine Dev] Bugs in the data categories and search bar

Julie Sullivan julie at flymine.org
Tue Oct 4 13:20:22 BST 2011


1. Those links don't work for me, so it's not clear what's going wrong.  Can you 
run the "bad" query and look in the log files.  Is there an error message?

2. This bug is fixed in 0.98.  Here is the fix if you want to copy it over to 
your 0.97 checkout:

	http://intermine.org/changeset/27933

On 04/10/11 13:07, James Blackshaw wrote:
> Hi,
> We've had a couple of bug reports about MitoMiner that we think are down to
> issues with Intermine itself. When we tag queries with an Aspect so that they
> show up on the Data Category page, sometimes the link generated isn't a valid
> one. For example, our OMIM-related templates:
>
> Working link:
> http://bio3.mrc-mbu.cam.ac.uk/release-2.0/template.do?name=New%20OMIM%20Query%202&scope=global&idForLookup=&trail=
>
>
> Broken link:
> http://bio3.mrc-mbu.cam.ac.uk/release-2.0/template.do?name=OMIM_Search&scope=global&idForLookup=&trail=
>
>
> Also we've had a user note that the Quick Search box doesn't take Boolean search
> terms. This was the feedback we recieved:
> - Searching the database by keywords (simple query using the search box):
> Boolean search syntax seems do not work properly, the following example are
> reported to explain the problem:
> 1. Search results 1 to 100 out of 287 for "kinase AND human"
> 2. Search results 1 to 3 out of 3 for "kinase OR human" (here I should get more
> results than in the query above)
> 3. Unfortunately, your search for "kinase AND NOT human" did not return any
> results (is it possible?), the search in mouse demonstrate that there are at
> least 77 entries for kinase in mouse (Search results 1 to 77 out of 77 for
> "kinase AND mouse"), so I should get at least these entries.
>
> Regards,
> James
>
>
> _______________________________________________
> dev mailing list
> dev at intermine.org
> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
>



More information about the dev mailing list