[InterMine Dev] [Fwd: Exporting data to Galaxy]

Fengyuan Hu fh293 at cam.ac.uk
Wed Sep 7 11:35:53 BST 2011


Hi Brian,

Normally a log file called "intermine.log" will be generated in the dir 
where you launch your tomcat, in my case, it's under tomcat/bin/, in the 
file you should see all the logs you'd like to print out in your java 
class. Could you look for it?

Cheers
Fengyuan

On 06/09/11 18:28, Lewis, Brian Andrew wrote:
>
> Fengyuan --
>
> I added that line to the code but I'm not getting any output from the 
> log.  The following property is present in my intermine.properties 
> file in the home directory, so I would think it should be working:
>
> webapp.logdir=/usr/local/apache-tomcat-6.0.33/logs/
>
> I also checked the logging properties for Tomcat and all logs are set 
> to "INFO" level.
>
> This is the only output I'm seeing in catalina.out:
>
> Sep 6, 2011 1:20:14 PM org.apache.catalina.loader.WebappClassLoader 
> clearReferencesJdbc
>
> SEVERE: The web application [/nntcmine] registered the JDBC driver 
> [org.postgresql.Driver] but failed to unregister it when the web 
> application was stopped. To prevent a memory leak, the JDBC Driver has 
> been forcibly unregistered.
>
> Sep 6, 2011 1:20:14 PM org.apache.catalina.loader.WebappClassLoader 
> clearReferencesThreads
>
> SEVERE: The web application [/nntcmine] appears to have started a 
> thread named [WriteBatch Flusher] but has failed to stop it. This is 
> very likely to create a memory leak.
>
> Sep 6, 2011 1:20:14 PM org.apache.catalina.loader.WebappClassLoader 
> clearReferencesThreads
>
> SEVERE: The web application [/nntcmine] appears to have started a 
> thread named [Thread-47] but has failed to stop it. This is very 
> likely to create a memory leak.
>
> Sep 6, 2011 1:20:14 PM org.apache.catalina.startup.HostConfig 
> checkResources
>
> INFO: Undeploying context [/nntcmine]
>
> Sep 6, 2011 1:20:15 PM org.apache.catalina.startup.HostConfig deployWAR
>
> INFO: Deploying web application archive nntcmine.war
>
> And here's the output from localhost.2011-09-06.log file:
>
> Sep 6, 2011 1:20:14 PM org.apache.catalina.core.ApplicationContext log
>
> INFO:  [CompressingFilter/1.7] CompressingFilter is being destroyed...
>
> Sep 6, 2011 1:20:15 PM org.apache.catalina.core.ApplicationContext log
>
> INFO:  [CompressingFilter/1.7] CompressingFilter has initialized
>
> Sep 6, 2011 1:20:15 PM org.apache.catalina.core.ApplicationContext log
>
> INFO: action: []: Verifying ModuleConfig for this module
>
> Sep 6, 2011 1:20:15 PM org.apache.catalina.core.ApplicationContext log
>
> INFO: action: []: null
>
> Sep 6, 2011 1:20:15 PM org.apache.catalina.core.ApplicationContext log
>
> INFO: action: []: Verification of ModuleConfig has been completed
>
> ~ Brian
>
> *From:*Fengyuan Hu [mailto:fh293 at cam.ac.uk]
> *Sent:* Tuesday, September 06, 2011 12:06 PM
> *To:* Lewis, Brian Andrew
> *Cc:* dev at intermine.org
> *Subject:* Re: [Fwd: [InterMine Dev] Exporting data to Galaxy]
>
> Hi Brian,
>
> I've just tested it on 0.97, but it worked fine for me.
>
> The URL is generate in GalaxyExportOptionsController.java line 195, 
> could you please print "link" out in the log?
>
> LOG.info("URL to Galaxy:\n" + link);
>
> Cheers
> Fengyuan
>
> On 06/09/11 15:26, Lewis, Brian Andrew wrote:
>
> It is 0.97, which is the latest version.
>
> ~ Brian
>
> *From:*Fengyuan Hu [mailto:fh293 at cam.ac.uk]
> *Sent:* Tuesday, September 06, 2011 10:17 AM
> *To:* Lewis, Brian Andrew
> *Cc:* dev at intermine.org <mailto:dev at intermine.org>
> *Subject:* Re: [Fwd: [InterMine Dev] Exporting data to Galaxy]
>
> Hi Brian,
>
> Based on the fact that you can actually send intermine data to Galaxy 
> and the URL value is null, it should be an intermine issue. It looks 
> to me you are working with a fairly old version of intermine, what 
> version is it?
>
> Cheers
> Fengyuan
>
> On 06/09/11 15:08, Lewis, Brian Andrew wrote:
>
> Fengyuan --
>
> I just checked and it looks like the 'URL' field is not being 
> generated correctly (see attached image) since the value is blank.  
> Unfortunately the server isn't public, so I can't give you the URL.  I 
> did attach my intermine.properties file as well, with some server 
> details removed.
>
> I did create a new data source tool for Galaxy and it is pointing to 
> the correct URL of our InterMine instance.
>
> Because of the nature of the issue, I really wasn't sure if this was a 
> question for Galaxy's dev mailing list or InterMine's.
>
> Thanks,
>
> ~ Brian
>
> *From:*Fengyuan Hu [mailto:fh293 at cam.ac.uk]
> *Sent:* Monday, September 05, 2011 8:23 AM
> *To:* Lewis, Brian Andrew
> *Cc:* dev at intermine.org <mailto:dev at intermine.org>
> *Subject:* Re: [Fwd: [InterMine Dev] Exporting data to Galaxy]
>
> Dear Brian,
>
> Sorry for the slow reply.
>
> First of all, it seems you've set up galaxy config in InterMine the 
> right way. I've tried to reproduce your error, but it works fine for 
> me to send data from a local InterMine to a local Galaxy.
>
> The "URL" content should be programmatically generated by InterMine. 
> Is your server public for me to test on? Or can you inspect it by 
> firebug in firefox or chrome on the export page, there should be a 
> hidden field called "URL" (see screenshot attached). Can you find it 
> in your page? A further question is, did you create a new data_souce 
> tool 
> <http://wiki.g2.bx.psu.edu/Admin/Tools/Tool%20Config%20Syntax#A.3Ctool.3E_tag_set>  
> for your mine or you are using an existing tool, such as modmine or 
> flymine, etc. (this is set in web.properties as for "galaxy.url.value" 
> key)?
>
> I've also checked the source code for Galaxy data_source 
> (galaxy-dist/tools/data_souce/data_source.py) , the error is indeed 
> caused by the missing "URL" parameter in the http request. It looks 
> quite odd to me so far.
>
> Thanks
> Fengyuan
>
> On 05/09/11 10:39, julie at flymine.org <mailto:julie at flymine.org> wrote:
>
> ---------------------------- Original Message ----------------------------
> Subject: [InterMine Dev] Exporting data to Galaxy
> From:    "Lewis, Brian Andrew"<brilewis at iupui.edu>  <mailto:brilewis at iupui.edu>
> Date:    Fri, September 2, 2011 6:53 pm
> To:"dev at intermine.org"  <mailto:dev at intermine.org>  <dev at intermine.org>  <mailto:dev at intermine.org>
> --------------------------------------------------------------------------
>   
> I'm in the process of hooking up our instance of InterMine to an instance
> of Galaxy (on the same server).  I figured out that I need to added the
> section to tiles-defs-model.xml and modify the web.properties file as
> well.  After re-deploying my mine, I'm able to get to the "Export to
> Galaxy" page.  When I click "Export", the job does go to Galaxy but I get
> the following error message back from Galaxy:
>   
> An error occurred running this job: The remote data source application has
> not sent back a URL parameter in the request.
>   
> To anyone with experience hooking up these two apps, could you let me know
> how to set this URL parameter?
>   
> Thanks,
> Brian Lewis
> _______________________________________________
> dev mailing list
> dev at intermine.org  <mailto:dev at intermine.org>
> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.intermine.org/pipermail/dev/attachments/20110907/95f56bb5/attachment-0001.html>


More information about the dev mailing list