[InterMine Dev] Error downloading data via perl script

Julie Sullivan julie at flymine.org
Thu Sep 8 09:21:22 BST 2011


Hi Brian

Yes, sorry, we're in the middle of migrating to the new system although I 
thought the old scripts still worked.

Unfortunately the new system isn't documented yet but will be shortly.  In the 
meantime, here are the modules you need to install:

	http://intermine.org/wiki/InstallingPerlModules

Then you add a configuration file to set the destination directories for the 
logs and data files.  Here's flymine's:

	bio/scripts/DataDownloader/config/flymine.yml

So create and update of the copy of that file:

	bio/scripts/DataDownloader/config/nntcmine.yml

Then you run the scripts like so:

bio/scripts/DataDownloader$ perl bin/download_data -e nntcmine

Or to run a single source, do this:

bio/scripts/DataDownloader$ perl bin/download_data -e nntcmine IntactVocabulary

help

	perl bin/download_data -h

list of available sources:

	perl bin/download_data -s

The perl modules are here, so you can see where the files are coming from:

	bio/scripts/DataDownloader/lib/DataDownloader/Source

Let me know if that works for you.

Cheers,
Julie

On 07/09/11 22:19, Lewis, Brian Andrew wrote:
> I recently discovered that there were shell scripts in bio/scripts that automatically download data from public database to a server directory.  When I tried running one of the scripts (get_psi_ontology), I got the following error:
>
> Can't locate DataDownloader.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /../../intermine/perl/lib/) at get_psi_ontology line 15.
> BEGIN failed--compilation aborted at get_psi_ontology line 15.
>
> Pretty easy fix - just install the perl module.  After that I tried running the script again and got almost the same error:
>
> Use of uninitialized value in concatenation (.) or string at get_psi_ontology line 13.
> Can't locate InterMine/DataDownloader.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /../../intermine/perl/lib/) at get_psi_ontology line 15.
> BEGIN failed--compilation aborted at get_psi_ontology line 15.
>
> I've tried adding a statement similar to the following below the push(@INC... statement but I keep getting the "Can't locate..." error.
>
> use '/usr/local/intermine_0_97/bio/scripts/DataDownloader/lib';
>
> Any suggestions?
>
> Thanks,
> Brian
>
>
>
>
> _______________________________________________
> dev mailing list
> dev at intermine.org
> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev



More information about the dev mailing list