[InterMine Dev] Error downloading data via perl script

Lewis, Brian Andrew brilewis at iupui.edu
Thu Sep 8 15:42:56 BST 2011


Julie -



Well, I was able to get farther this time after creating the nntcmine.yml file in the config directory.  When I run the command: perl bin/download_data -e nntc_data InterPro I get the following error:



Cannot use setting from bin/../config/nntc_data.yml as it does not exist.



Usage: download_data -e flymine Uniprot

at bin/download_data line 88

        main::read_config('bin/../config/nntc_data.yml') called at bin/download_data line 59



So are there two files that need to exist?  Just to see what would happen I copied the nntcmine.yml file to nntc_data.yml and I got a different error when executing the download_data script:



Died at /usr/local/share/perl5/YAML/Loader.pm line 676, <$IN> line 1.



~ Brian



Date: Thu, 08 Sep 2011 09:21:22 +0100

From: Julie Sullivan <julie at flymine.org<mailto:julie at flymine.org>>

To: dev at intermine.org<mailto:dev at intermine.org>

Subject: Re: [InterMine Dev] Error downloading data via perl script

Message-ID: <4E687B02.6000405 at flymine.org<mailto:4E687B02.6000405 at flymine.org>>

Content-Type: text/plain; charset=ISO-8859-1; format=flowed



Hi Brian



Yes, sorry, we're in the middle of migrating to the new system although I thought the old scripts still worked.



Unfortunately the new system isn't documented yet but will be shortly.  In the meantime, here are the modules you need to install:



                http://intermine.org/wiki/InstallingPerlModules



Then you add a configuration file to set the destination directories for the logs and data files.  Here's flymine's:



                bio/scripts/DataDownloader/config/flymine.yml



So create and update of the copy of that file:



                bio/scripts/DataDownloader/config/nntcmine.yml



Then you run the scripts like so:



bio/scripts/DataDownloader$ perl bin/download_data -e nntcmine



Or to run a single source, do this:



bio/scripts/DataDownloader$ perl bin/download_data -e nntcmine IntactVocabulary



help



                perl bin/download_data -h



list of available sources:



                perl bin/download_data -s



The perl modules are here, so you can see where the files are coming from:



                bio/scripts/DataDownloader/lib/DataDownloader/Source



Let me know if that works for you.



Cheers,

Julie



On 07/09/11 22:19, Lewis, Brian Andrew wrote:

> I recently discovered that there were shell scripts in bio/scripts that automatically download data from public database to a server directory.  When I tried running one of the scripts (get_psi_ontology), I got the following error:

>

> Can't locate DataDownloader.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /../../intermine/perl/lib/) at get_psi_ontology line 15.

> BEGIN failed--compilation aborted at get_psi_ontology line 15.

>

> Pretty easy fix - just install the perl module.  After that I tried running the script again and got almost the same error:

>

> Use of uninitialized value in concatenation (.) or string at get_psi_ontology line 13.

> Can't locate InterMine/DataDownloader.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 . /../../intermine/perl/lib/) at get_psi_ontology line 15.

> BEGIN failed--compilation aborted at get_psi_ontology line 15.

>

> I've tried adding a statement similar to the following below the push(@INC... statement but I keep getting the "Can't locate..." error.

>

> use '/usr/local/intermine_0_97/bio/scripts/DataDownloader/lib';

>

> Any suggestions?

>

> Thanks,

> Brian

>

>

>

>

> _______________________________________________

> dev mailing list

> dev at intermine.org<mailto:dev at intermine.org>

> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.intermine.org/pipermail/dev/attachments/20110908/c851feca/attachment.html>


More information about the dev mailing list