[InterMine Dev] error:Code point \u0000 is not a valid character in XML

Dr. Intikhab Alam intikhab.alam at kaust.edu.sa
Fri Mar 16 13:23:31 GMT 2012


I am converting a gff containing information regarding genes of my
interest, it may come from there. There were a few '' characters which I
removed and tried again. Getting the same error again.

The error is report while reading entry AT0200m01B1.GI0EXFF02C9LQB, I have
included here this and the next entries. Looking at sequence length, I
find out there are some strange illumina nextgen sequence quality
characters which should not be there.

AT0200m01B1.GI0EXFF02C9LQB      MGA     gene    2       151     50      -
     0       
ID=gene.AT0200m01B1.GI0EXFF02C9LQB.1;locus_tag=AT0200m01B1.GI0EXFF02C9LQB;N
ote=GeneStatus:lack 3'
end;transl_table=11;protein_id=prot.AT0200m01B1.GI0EXFF02C9LQB.1;translatio
n=MKQEFNILVNVIKDFTAPAYPYEVEPDADIKTEDFDDRIDVQPVSDPNSA
AT0200m01B1.GI0EXFF02C9LQB      MGA     gene    158     11305   9       +
     1       
ID=gene.AT0200m01B1.GI0EXFF02C9LQB.2;locus_tag=AT0200m01B1.GI0EXFF02C9LQB;N
ote=GeneStatus:lack 3'
end;transl_table=11;protein_id=prot.AT0200m01B1.GI0EXFF02C9LQB.2;translatio
n=MKSGLNSAH



I will try removing them and re-run the script to produce the xml,
hopefully this should resolve the error.
Intikhab





On 3/16/12 1:00 PM, "Alex Kalderimis" <alex at intermine.org> wrote:

>That character (the null character) should not be part of a string in
>XML. Do you know how it got in there?
>
>Alex
>
>On 16/03/12 10:32, Dr. Intikhab Alam wrote:
>> Hi everybody,
>> 
>> While writing xml file to load data in my mine, I get the following
>>error:
>> 
>> Code point \u0000 is not a valid character in XML at
>> /usr/local/share/perl/5.12.4/InterMine/Item.pm line 493
>> 
>> I can not how to remove/replace this code point using perl script I am
>> using to make an xml for data load.
>> 
>> Any help, please.
>> 
>> Intikhab
>> 
>> 
>> _______________________________________________
>> dev mailing list
>> dev at intermine.org
>> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
>
>_______________________________________________
>dev mailing list
>dev at intermine.org
>http://mail.intermine.org/cgi-bin/mailman/listinfo/dev




More information about the dev mailing list