[InterMine Dev] missing directories while building a new mine.

Julie Sullivan julie at flymine.org
Tue Nov 6 13:12:54 GMT 2012


Hi Allan

I'm glad you got your build working. We discovered this bug a couple of months 
ago when we migrated to Git from Subversion. Apparently we missed all of the 
empty directories and our ant tasks stupidly expect all directories to always be 
there.

We fixed this issue by adding .gitignore files to the empty directories.

I just tested this on a new mine and everything worked fine for me. Can you try 
again?

I'm on the master branch:

	$ git branch
	  dev
	* master

I ran this command:

	~/git/intermine $ ./bio/scripts/make_mine NewMine
	created /home/julie/git/intermine/newmine directory for NewMine

And I have all the directories you are missing:

	~/git/intermine $ ls -a newmine/integrate/resources/
	.  ..  .gitignore
	~/git/intermine $ ls -a newmine/integrate/src/
	.  ..  .gitignore
	~/git/intermine $ ls -a newmine/postprocess/src/
	.  ..  .gitignore
	~/git/intermine $ ls -a newmine/postprocess/main/src/
	.  ..  .gitignore
	~/git/intermine $ ls -a newmine/postprocess/main/resources/
	.  ..  .gitignore

The directory structure for new mines is set using the bio/skeleton directory. 
Here is the change fixing this bug, it's 4 months old:

https://github.com/intermine/intermine/tree/master/bio/skeletons/mine/postprocess/src

So I'm not sure what's going on!

Also, once you start building using lots of sources, you may run out of memory. 
If that happens, you should use the project_build script.

	http://intermine.org/wiki/RunningABuild

Thanks
Julie

On 06/11/12 12:40, Allan Kamau wrote:
> When creating a new mine using the master branch obtained from the GitHub
> at approximately 1300hrs GMT on 2012-Nov-05. I am experiencing the
> following errors.
>
> When running "ant -v -Dsource=all" at the integration step when within the
> integrate directory of my newly create mine source directory, the build
> fails because the following directories are required.
>
> ../integrate/src and ../integrate/resources
>
> The build completes successfully once I manually create these two
> directories and rerun the "ant -v -Dsource=all" command.
>
> Also the postprocess step (from within the "postprocess" directory of my
> newly created mine source directory) fails on not finding the directories
> "../postprocess/main/src", "../postprocess/main/resources" and
> "../postprocess/src". When I manually create these three directories, the
> "ant -v" build process runs to completion successfully.
>
>
> Allan.
>
>
>
>
> _______________________________________________
> dev mailing list
> dev at intermine.org
> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev



More information about the dev mailing list