[InterMine Dev] setting up chado (tripal) intermine

Sofia Robb sofia at sofiarobb.com
Sun Dec 7 00:41:21 GMT 2014


Hi Julie,
Thank you so much. I made the change and that error is gone, but now I have
another

BUILD FAILED
/data/src/intermine/imbuild/library.xml:78: The following error occurred
while executing this line:
/data/src/intermine/imbuild/objectstore.xml:93:
java.lang.NullPointerException: Datasource is null. Properties are:
{datasource.port=5432, datasource.user=intermine, platform=PostgreSQL,
datasource.databaseName=simrmine, datasource.serverName=localhost,
driver=org.postgresql.Driver, datasource.password=xxxx,
datasource.maxConnections=50}

Here is the excerpt from my ~/.intermine/simrmine.properties

db.production.datasource.serverName=localhost
db.production.datasource.port=5432
db.production.datasource.databaseName=simrmine
db.production.datasource.user=intermine
db.production.datasource.password=xxxxx

I have no problems when log into the simrmine database manually with psql
with the user intermine and the password. I double checked the port, and it
is 5432.

Thank you for your help!
Sofia

On Tue, Dec 2, 2014 at 12:37 PM, Julie Sullivan <julie at flymine.org> wrote:

> Hi Sofia!
>
> All your files look fine to me. This line from the tutorial:
>
>         (cd ../dbmodel && ant build-db -v); ant -Dsource=chado-db -v
>
> Assumes that your source is called chado-db. You have named your source in
> your project XML "drupal".
>
> So try this instead:
>
>         (cd ../dbmodel && ant build-db -v); ant -Dsource=drupal -v
>
> Julie
>
> ----
>
>
> Hello.
>
> I am having issues trying to set up my intermine from a chado database
> (actually a chado database within a tripal database).
>
> I am following the steps in
> http://intermine.readthedocs.org/en/latest/database/data-
> sources/library/chado/#index-0
> but
> feel as if I must be missing something.
>
> ERROR:
>
> BUILD FAILED
> /data/src/intermine/imbuild/integrate.xml:54: can't find source in project
> definition file: chado-db
>
> my ~/.intermine/simrmine.properties:
> db.flybase.datasource.class=org.postgresql.ds.PGPoolingDataSource
> db.flybase.datasource.dataSourceName=db.flybase
> db.flybase.datasource.serverName=localhost
> db.flybase.datasource.port=5432
> db.flybase.datasource.databaseName=drupal
> db.flybase.datasource.user=xxxx
> db.flybase.datasource.password=xxxx
> db.flybase.datasource.maxCommections=10
> db.flybase.datasource.driver=org.postgresql.Driver
> db.flybase.datasource.platform=PostgreSql
>
> my project.xml:
> <source name="drupal" type="chado-db" dump="true">
>   <property name="source.db.name" value="flybase"/>
>   <property name="genus" value="Schmidtea"/>
>   <property name="species" value="mediterranea"/>
>   <property name="dataSourceName" value="Flybase"/>
>   <property name="dataSetTitle" value="SmedSxl_v31 data set"/>
>   <property name="converter.class"
> value="org.intermine.bio.dataconversion.ChadoDBConverter"/>
>   <property name="processors"
> value="org.intermine.bio.dataconversion.SequenceProcessor"/>
> </source>
>
> Thanks,
> Sofia
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.intermine.org/pipermail/dev/attachments/20141206/fc778b3a/attachment.html>


More information about the dev mailing list