[InterMine Dev] gene ontology display problem

Pengcheng Yang yangpc at biols.ac.cn
Wed Aug 5 00:52:05 BST 2015


Hi Julie Sullivan,

Thank you for your help.

Following your suggestion, I have 1) loaded the GO data source, and then 
found the Gene ontology still can not be displayed on the gene report 
page. then I 2) removed the displayer from webconfig-model.xml file, 
indeed, as you said, there appeared two section in the Other group. But 
the content is empty as listed below. Is there any other thing I have 
missed and any other information I can provide to resolve this problem?

Thank you very much!

Best,
Pengcheng Yang


      4 GO Annotation

//Annotation Extension 	//Qualifier
	0
	0
	0
	0


      4 Ontology Annotations

//Annotation Extension 	//Qualifier
	0
	0
	0
	0



On 2015/8/4 17:17, Julie Sullivan wrote:
> You will have to load GO data source to use the GO data displayer on 
> the report page.
>
> You can still query for the data. You could also remove the displayer 
> from the XML file and it might show the raw data on the report page 
> instead. Try that?
>
> On 04/08/15 10:13, Pengcheng Yang wrote:
>> Hi Julie Sullivan,
>>
>> I have created the query using "import query from xml", changed the
>> "eve" to the gene id in mymine. But nothing returned.
>>
>> I have the following information to share:
>> 1) I haven't load the go data because the long time need and I just want
>> to test the go-annotation data.
>> 2) I have loaded go-annnotation data, which can be valided by "select *
>> from genegoannotation", and the gene report page give a link to the Data
>> Set of GOannotation page. When I click to the latter page, there will
>> display all the genes with GO annotation. When I click "Showl all in a
>> table", and then add the columns "Manage Columns" and add "Ontology
>> Name", "Ontology Term Identifier" and "Ontology Term Name", nothing
>> returned.
>> 3) I want to display the gene ontology information on the gene report
>> webpage.
>>
>> Many thanks!
>>
>> Best,
>> Pengcheng Yang
>>
>> On 2015/8/4 16:38, Julie Sullivan wrote:
>>> All evidence codes should work.
>>>
>>> This is the query that displayer runs:
>>>
>>> <query name="" model="genomic"
>>> view="Gene.goAnnotation.ontologyTerm.parents.name
>>> Gene.goAnnotation.ontologyTerm.name
>>> Gene.goAnnotation.evidence.code.code" longDescription=""
>>> sortOrder="Gene.goAnnotation.ontologyTerm.parents.name asc"
>>> constraintLogic="(A or B or C) and D">
>>>   <constraint path="Gene.goAnnotation.ontologyTerm.parents.name"
>>> code="A" op="=" value="biological_process"/>
>>>   <constraint path="Gene.goAnnotation.ontologyTerm.parents.name"
>>> code="B" op="=" value="molecular_function"/>
>>>   <constraint path="Gene.goAnnotation.ontologyTerm.parents.name"
>>> code="C" op="=" value="cellular_component"/>
>>>   <constraint path="Gene" code="D" op="LOOKUP" value="eve"
>>> extraValue=""/>
>>> </query>
>>>
>>>
>>> Run that query in your own mine. Do you get results?
>>>
>>> To run that query, go to the QueryBuilder tab, click on "import query
>>> from xml. Copy and paste the above and click on submit. This query is
>>> looking for the fruit fly gene "eve". You'll want to replace "eve"
>>> with the identifier for your gene. Let me know if you need help.
>>>
>>>
>>>
>>>
>>>
>>> On 04/08/15 09:19, Pengcheng Yang wrote:
>>>> Hi,
>>>>
>>>> I have loaded go-annotation, and "select   * from genegoannotation;"
>>>> return two columns of gene and goannotation. However, when I 
>>>> checked the
>>>> gene report page, the gene ontology display always nothing although
>>>> there indeed GO annotation for that gene. I have searched mail archive
>>>> and found a similar questions has been asked:
>>>> http://gmod.827538.n3.nabble.com/GO-evidence-td4026625.html. The
>>>> evidences in my go-annotation file all are "IEA". Is this the reason?
>>>>
>>>> The gene ontology displayer part in the
>>>> mymine/webapp/resources/webapp/WEB-INF/webconfig-model.xml is:
>>>>
>>>>     <reportdisplayer
>>>> javaClass="org.intermine.bio.web.displayer.GeneOntologyDisplayer"
>>>> jspName="model/geneOntologyDisplayer.jsp"
>>>> replacesFields="goAnnotation,ontologyAnnotations"
>>>>                       placement="Genomics"
>>>>                       types="Gene"/>
>>>>
>>>> Thanks a lot!
>>>>
>>>> Any suggestions are appreciated.
>>>>
>>>> Best,
>>>> Pengcheng Yang
>>>>
>>>>
>>>> _______________________________________________
>>>> dev mailing list
>>>> dev at intermine.org
>>>> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
>>>>
>>>
>>
>>
>>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.intermine.org/pipermail/dev/attachments/20150805/4b152ae7/attachment-0001.html>


More information about the dev mailing list