[InterMine Dev] Launching and debugging intermine project with Eclipse

Doug Bryant Jr. bryantd at gmail.com
Tue May 19 18:20:37 BST 2015


Thanks, this worked for me. Much appreciated.

On Mon, May 18, 2015 at 8:33 PM Joe Carlson <jwcarlson at lbl.gov> wrote:

> On May 18, 2015, at 1:38 PM, Doug Bryant Jr. <bryantd at gmail.com> wrote:
>
> Hi all,
>
> I set up our intermine project in eclipse, and would now like to launch
> the project via eclipse in order to set breakpoints for debugging. Is
> method for doing so documented somewhere?
>
> Hi Doug,
>
>
> Here is what works for me:
>
> 1) start up tomcat with a port open for monitoring
>
> Make a copy tomcat’s bin/startup.sh - call it debug_startup.sh -  make a
> version and defines the environment variable
>
> export JPDA_OPTS=-agentlib:jdwp=transport=dt_socket,address=<your host
> name>:8069,server=y,suspend=y
>
> or, whatever port is free is 8069 is being used.
>
> And replace the final line with
>
> exec "$PRGDIR"/"$EXECUTABLE" jpda start "$@“
>
> 2) Go to eclipse and debug as a remote java application. You just need to
> specify the host of tomcat and the port that you listed. You’ll need to
> have a browser window or web service call to get things going.
>
> Hope it helps,
>
> Joe Carlson
>
> Thanks.
> _______________________________________________
> dev mailing list
> dev at intermine.org
> http://mail.intermine.org/cgi-bin/mailman/listinfo/dev
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.intermine.org/pipermail/dev/attachments/20150519/fa0d680d/attachment.html>


More information about the dev mailing list