[InterMine Dev] GeneStructureDisplayer throwing NullPointerException - any ideas?

Krishnakumar, Vivek vkrishna at jcvi.org
Wed Apr 27 23:56:51 BST 2016


Hi Sam,

Just a thought: I've seen NullPointerExceptions in the past with this
displayer when the entrez-organism source was not run, i.e. the organism
information is not populated.

Could this be your issue?

Thanks.
Vivek

On Wed, Apr 27, 2016, 6:53 PM Sam Hokin <shokin at ncgr.org> wrote:

> Hi, devs. I've got two mines that are extremely similar, both pulling
> genomic data from the same chado database. In both cases the
> objects associated with genes are populated in the same way, namely:
> transcripts=yes, exons=yes, CDSs=no, introns=no, UTRs=no,
> fivePrimeUTR=no, threePrimeUTR=no. I mention these because they are what
> GeneStructureDisplayer replaces in the Gene report.
>
> However, one of the mines has no error in GeneStructureDisplayer; it shows
> the list of transcripts and their exons as it should. In
> the other mine, GeneStructureDisplayer throws a NullPointerException which
> is, to me, totally uninformative. Since the mines, and
> webconfig-model.xml, are identical in structure, I can't figure out where
> to start looking.
>
> I've attached the full stack trace when I request a Gene report page. I'd
> really appreciate any ideas on where to look to get the
> GeneStructureDisplayer to work on this mine!
> _______________________________________________
> dev mailing list
> dev at lists.intermine.org
> https://lists.intermine.org/mailman/listinfo/dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.intermine.org/pipermail/dev/attachments/20160427/b8f13e28/attachment.html>


More information about the dev mailing list